Environment
- YugabyteDB Anywhere - All
Issue
Backup task failed with returned non-zero exit status 11. The following error message was reported in YBA application logs:
WARNING: Could not refresh role
ERROR: S3 error: 400 (ExpiredToken): The provided token has expired.
Cause
The s3 token expired before the backup could complete.
For an AWS IAM role the default Maximum session duration is set to 1hr. In the YBA backup config, if we are using the instance's role session, then this timeout of 1hr comes into picture.
Resolution
Option 1
In AWS, set Maximum Session Duration of the instance's IAM role from 1hr -> 8 hrs so that the backup could complete before the session expires.
Option 2
Turn off the IAM role toggle in AWS backup config and use static credentials instead so that it won't timeout.
Comments
0 comments
Please sign in to leave a comment.