Environment:
All versions of Yugaware platform
Issue:
The application.log for the universe shows the following error:
Universe version does not match cluster config version
Root Cause:
The error occurs when the change is made for the universe outside of the platform i.e potentially via the yb-admin command. The universe version becomes "out of sync" with the version recorded in the platform. It is also possible that Platform and DB versions are not in sync anymore.
This occurs as the platform does not know about any modifications to the universe made outside of the platform. These changes could be overwritten on the next operation or task execution.
Resolution:
To resolve this issue platform supports an API request to the following endpoint to reset the universe version.
Below is the API request for 2DC setup:
PUT /customers/:cUUID/universes/:uniUUID/setup_universe_2dc
In some cases, the API also typically requires an API token and there is a specific curl syntax like below
curl -X PUT -H 'X-AUTH-YW-API-TOKEN: <API TOKEN value>' http://portal.dev.yugabyte.com/customers/:cUUID/universes/:uniUUID/setup_universe_2dc
To find Customer UUID: We typically get this by opening up the Chrome network inspector and watching for requests that have the customer UUID. Below steps show how to find the customer UUID:
Step 1: Right Click on UI (platform) you will see an option "Inspect" Click on that
Step 2: Reload the UI (platform) and you will see the "network tab" (as shown in screenshot) and click on certificates where you will see "Customer UUID"
For more details about API follow the bellow doc link
Deploy to two data centers with asynchronous replication | YugabyteDB Docs
Future releases of the Yugaware Platform will have the fix. Please follow the Github issue: https://github.com/yugabyte/yugabyte-db/issues/7544.
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